empower Unplanned Outage
Incident Report for ABB empower
Resolved
Issue is now resolved. All empower functions are working.

Regards
ABB empower Team
Posted Aug 10, 2020 - 03:02 EDT
Monitoring
Issue has been resolved and all empower functions are now working as expected. Team will be monitoring for some more time.

Regards
ABB empower Team
Posted Aug 10, 2020 - 02:36 EDT
Identified
Issue has been identified and teams are working on resolving it now.

Regards
ABB empower Team
Posted Aug 10, 2020 - 02:23 EDT
Update
We are continuing to investigate this issue.
Posted Aug 10, 2020 - 02:14 EDT
Investigating
empower is currently experiencing issues with interfacing applications. This is affecting some users' ability to do Order Tracking, Price & Availability, Order Entry and others. Orders placed from empower Quote will be held and processed later. Teams are working on resolving the issue. Updates will be posted here.

Regards,
ABB empower team
Posted Aug 10, 2020 - 02:03 EDT
This incident affected: empower Flow (Order Status & Tracking, Price & Availability, Price Delivery, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service) and empower Quote (Quote Management, Project Pricing, Project Orders).