empower currently experiencing issues
Incident Report for ABB empower
Resolved
Issue is now resolved. All empower functions are working as expected.

Regards
ABB empower Team
Posted Jan 09, 2021 - 11:47 EST
Investigating
empower is currently experiencing connectivity issues across the application. This is affecting users' ability to view price & availability information and track and place orders.

Other areas of empower - such as empower-Quote - are not impacted, though order placement may be delayed.

Please visit https://status.empower.abb.com/ for further updates.

Regards
ABB empower team
Posted Jan 09, 2021 - 06:51 EST
This incident affected: empower Flow (Order Status & Tracking, Price & Availability, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service).