empower: Login - ABB SSO Login experiencing issues
Incident Report for ABB empower
Resolved
The incident has been resolved.
Posted Jul 18, 2023 - 10:20 EDT
Investigating
empower is currently experiencing issues with ABB SSO login and users are experiencing problems when attempting to log into empower.

Users previously authenticated are still able to get into empower and access all modules and functions

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Jul 18, 2023 - 09:22 EDT
This incident affected: empower ABB SSO authentication.