empower currently experiencing issues with the ABB SSO authentication
Incident Report for ABB empower
Resolved
empower has been restored to full functionality. The issues affecting ABB LOGIN have been resolved.


Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted May 10, 2023 - 16:51 EDT
Monitoring
empower access has been restored and the team is monitoring performance. The issues affecting ABB LOGIN have been resolved.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted May 10, 2023 - 10:28 EDT
Investigating
empower is currently experiencing issues across the ABB SSO Logon component. This is affecting users' ability to log into empower.

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted May 08, 2023 - 08:30 EDT
This incident affected: empower ABB SSO authentication.