empower Login- ABB SSO Login degraded performance / slow response
Incident Report for ABB empower
Resolved
empower has been restored to full functionality. The issues affecting ABB SSO Login have been resolved.

If you are still experiencing issues, please contact empoweru@abb.com.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Mar 13, 2024 - 10:14 EDT
Investigating
empower is currently experiencing issues with ABB SSO login - Login/Auth page very slow response is impacting user ability to login. (over 3 minutes to process)

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Mar 13, 2024 - 08:46 EDT
This incident affected: empower ABB SSO authentication.