empower Intermittent Login Issues
Incident Report for ABB empower
Resolved
Issue is now resolved. empower is working as expected.

Regards,
ABB empower Team
Posted Jan 10, 2023 - 07:24 EST
Identified
The issue has been identified and is currently effective Users who are logging in from few locations. Teams are working on resolving the issue.

Regards,
ABB empower Team
Posted Jan 10, 2023 - 07:13 EST
Investigating
We are currently experiencing intermittent issues with login and authentication. The technical team is investigating for the root cause and working on re-establishing normal operations as soon as possible.

Regards,
ABB empower Team
Posted Jan 10, 2023 - 02:35 EST
This incident affected: empower Flow (Order Status & Tracking, Price & Availability, Price Delivery, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service) and empower Quote (Quote Management, Product Configuration, Project Pricing, Document Generation, Project Orders).