Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 23, 2025 - 20:00 EST
Scheduled
empower will be down due to SAP ERP scheduled maintenance beginning on THURSDAY at 8PM ET.
During this SAP MAINTENANCE event which will affect users' ability to use ANY functions of empower.
Full maintenance window: THU 8 PM EST - MON 6AM EST
Regards, ABB empower team
------------------------------------------------------------------------------------------------------------------------------------ This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Jan 22, 2025 - 09:38 EST
This scheduled maintenance affected: empower Flow (Order Status & Tracking, Price & Availability, Price Delivery, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service) and empower Quote (Quote Management, Product Configuration, Project Pricing, Document Generation, Project Orders).