empower: User Login issues
Incident Report for ABB empower
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 13:44 EDT
Investigating
empower is currently experiencing issues with ABB SSO login pages. This is affecting users' ability to log into empower.

All other modules of empower are currently operational for users already logged in.

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Jun 09, 2023 - 12:49 EDT
This incident affected: empower ABB SSO authentication.