Document Generation Issue
Incident Report for ABB empower
Resolved
This incident has been resolved.
Posted Oct 06, 2023 - 09:03 EDT
Investigating
We are currently experiencing issues in of generating/downloading documents and drawings inside empower Quote. The technical team is investigating for the root cause and working on reestablishing normal operations as soon as possible. For further information, please check for status updates.
Posted Oct 05, 2023 - 15:58 EDT
This incident affected: empower Quote (Document Generation).