Issue in empower Quote Pricing
Incident Report for ABB empower
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 17:42 EDT
Investigating
empower Quote is currently experiencing issues with Pricing. The appropriate technical teams have been notified and are actively working towards a resolution.
Posted Oct 16, 2023 - 09:45 EDT
This incident affected: empower Quote (Project Pricing).