empower – empower networking issues
Incident Report for ABB empower
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 09:14 EDT
Investigating
empower is experiencing network issues impacting response time and order submission. Please check your order status before resubmitting your order. The technical team is investigating the root cause and working towards a resolution.
Posted Aug 21, 2023 - 12:30 EDT
This incident affected: empower Flow (Order Status & Tracking, Price & Availability, Price Delivery, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service) and empower Quote (Quote Management, Product Configuration, Project Pricing, Document Generation, Project Orders).