Document Generation Issue
Incident Report for ABB empower
Resolved
This incident has been resolved.
Posted Jan 12, 2023 - 13:58 EST
Investigating
We are currently experiencing issues in of generating/downloading documents and drawings inside empower Quote documents. The technical team is investigating for the root cause and working on reestablishing normal operations as soon as possible. Check back for status updates.
Posted Jan 12, 2023 - 08:39 EST
This incident affected: empower Quote (Document Generation).