Empower application - FLOW issues
Incident Report for ABB empower
Resolved
empower has been restored to full functionality. The issues affecting empower FLOW have been resolved.

If you are still experiencing issues, please contact empoweru@abb.com.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Mar 25, 2024 - 14:09 EDT
Identified
A fix for the issue has been identified and is curently being redployed - empower expected to be fully operational in about 45 minutes.

empower QUOTE access remains functional and accessible at > https://empower.abb.com/quote

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team
Posted Mar 25, 2024 - 13:34 EDT
Update
empower is currently experiencing issues across the application. This is affecting users' ability to use all FLOW functions: Order tracking / PO tracking / mycart / returns / order management / rebates / pricing.

empower QUOTE access remains functional and accessible at > empower.abb.com/quote

Please visit https://status.empower.abb.com/ for further updates.

Regards,
ABB empower team

------------------------------------------------------------------------------------------------------------------------------------
This is an auto-generated email, please do not reply. For help, please visit https://empower.abb.com/help
Posted Mar 25, 2024 - 10:57 EDT
Investigating
We are experiencing issue with login and authentication into empower. The technical team is aware and is investigating the issue.
Posted Mar 25, 2024 - 08:57 EDT
This incident affected: empower Flow (Order Status & Tracking, Price & Availability, Price Delivery, Order Entry (shopping cart), Track Your Payables, Shipment Tracking, Post Sales Service).